ERD-Diagramme

Erstellen Sie Entity-Relationship-Diagramme (ERDs), um Datenbankstrukturen und Datenbeziehungen zu modellieren.

Was ist ein ERD?

Ein Entity-Relationship-Diagramm visualisiert:

  • Entitäten: Datenbanktabellen oder Objekte
  • Attribute: Eigenschaften von Entitäten
  • Beziehungen: Wie Entitäten miteinander verbunden sind
  • Kardinalität: Die Art der Beziehungen (Eins-zu-Eins, Eins-zu-Viele usw.)

Ein ERD erstellen

Entitäten hinzufügen

  1. Wählen Sie das Werkzeug Tabelle in der Werkzeugleiste und klicken Sie auf das Canvas, um für jede Entität eine Tabelle zu erstellen
  2. Verwenden Sie die erste Zeile als Entitätsname und die folgenden Zeilen für Attribute

Siehe Tabellen zum Bearbeiten von Zeilen, Spalten und Zelltext.

Jede Entität enthält typischerweise:

  • Entitätsname (Kopfzeile)
  • Primärschlüsselfeld(er)
  • Weitere Attribute

Beziehungen hinzufügen

  1. Wählen Sie das Verbindungslinienwerkzeug
  2. Zeichnen Sie eine Linie zwischen verwandten Entitäten
  3. Legen Sie passende Pfeilspitzen für die Kardinalität fest

Krähenfußnotation

Die Krähenfußnotation ist der gebräuchlichste ERD-Stil. Sie verwendet Symbole an Verbindungsenden, um die Kardinalität darzustellen.

Kardinalitätssymbole

SymbolBedeutung
`` (einzelne Linie)
○ (Kreis)Null (optional)
< oder > (Krähenfuß)Viele

Häufige Beziehungen

NotationAnfangEndeBedeutung
Eins-zu-Eins```
Eins-zu-Viele``<
Viele-zu-Viele<>Mehrere beziehen sich auf mehrere
Null-oder-Eins`○``
Null-oder-Viele○<``

Krähenfuß-Pfeilspitzen anwenden

  1. Wählen Sie eine Verbindungslinie zwischen Entitäten
  2. Gehen Sie im Tab Stil des Inspektors zum Abschnitt Connector
  3. Wählen Sie Anfangspfeil und Endpfeil aus der Liste Eingebaute Pfeilspitzen. Die ERD-Pfeilspitzen sind:
PfeilspitzeTypische Bedeutung
Bar BarGenau eins (‖)
Bar BallNull oder eins (○|)
Crows FeetViele
Crow BarEins oder viele (|<)
Crow BallNull oder viele (○<)

Crow Bar Segment und Crow Ball Circle sind alternative Zeichnungen der Enden für Eins-oder-Viele und Null-oder-Viele.

Sie können auch mit der rechten Maustaste auf das Ende einer Verbindungslinie klicken, um deren Pfeilspitze zu wählen.

Beispiel eines ERD-Arbeitsablaufs

Schritt 1: Entitäten identifizieren

Für eine E-Commerce-Datenbank:

  • Kunde
  • Bestellung
  • Produkt
  • Bestellposition

Schritt 2: Attribute definieren

Kunde

  • customer_id (PK)
  • name
  • email
  • phone

Bestellung

  • order_id (PK)
  • customer_id (FK)
  • order_date
  • total

Schritt 3: Entitäten zeichnen

  1. Erstellen Sie mit dem Werkzeug Tabelle eine Tabelle für jede Entität
  2. Fügen Sie Entitätsnamen als Kopfzeilen hinzu
  3. Listen Sie Attribute innerhalb jeder Tabelle auf
  4. Kennzeichnen Sie Primärschlüssel (PK) und Fremdschlüssel (FK)

Schritt 4: Beziehungen hinzufügen

  1. Zeichnen Sie eine Verbindungslinie von Kunde zu Bestellung
  2. Setzen Sie das „Eins"-Ende bei Kunde (|)
  3. Setzen Sie das „Viele"-Ende bei Bestellung (<)
  4. Dies zeigt: Ein Kunde hat viele Bestellungen

Schritt 5: Beziehungen beschriften

Fügen Sie Textbeschriftungen zu Verbindungslinien hinzu:

  • „bestellt" (Kunde → Bestellung)
  • „enthält" (Bestellung → Bestellposition)
  • „ist Produkt in" (Produkt → Bestellposition)

Best Practices für ERDs

Layout

  • Halten Sie verwandte Entitäten nah beieinander
  • Verwenden Sie einheitliche Entitätsgrößen
  • Richten Sie Entitäten in einem Rastermuster aus
  • Minimieren Sie sich kreuzende Verbindungslinien

Benennung

  • Verwenden Sie Substantive im Singular für Entitäten (Kunde, nicht Kunden)
  • Verwenden Sie einheitliche Namenskonventionen (camelCase, snake_case)
  • Beschriften Sie Beziehungen mit Verben

Dokumentation

  • Fügen Sie Primärschlüssel für alle Entitäten ein
  • Zeigen Sie Fremdschlüssel deutlich an
  • Erwägen Sie das Hinzufügen von Datentypen
  • Notieren Sie eventuelle Einschränkungen

Tipps

  • Mit Text beginnen: Fügen Sie ein Mermaid-erDiagram mit Bearbeiten → Mermaid einfügen (PRO) ein, um einen ersten Entwurf zu erhalten, und verfeinern Sie ihn dann — siehe Mermaid-Unterstützung
  • Auto-Layout verwenden: Hilft beim Organisieren komplexer Diagramme
  • Verwandte Entitäten gruppieren: Erstellt logische Abschnitte
  • Für Dokumentation exportieren: In technische Spezifikationen und Wikis einbinden
  • Versionskontrolle: Speichern Sie Iterationen, während sich Ihre Datenbank weiterentwickelt