ダイアグラムの書き出し

Diagrammixは、ドキュメント、プレゼンテーション、ウェブサイト、その他のアプリケーションで使用するために、さまざまな形式でダイアグラムを書き出せます。

書き出し形式

形式最適な用途ベクター/ラスター
PNGウェブ、ドキュメント、プレゼンテーションラスター
JPEG写真、ウェブ(小さいファイル)ラスター
PDF印刷、ドキュメント、アーカイブベクター
SVGウェブ、さらなる編集ベクター
VSDXMicrosoft Visioとの相互運用ベクター
ASCIIテキストコードコメント、ドキュメント、ターミナルテキスト

PNG(Portable Network Graphics)

  • 可逆圧縮
  • 透過をサポート
  • テキストやシャープなエッジのあるダイアグラムに最適
  • 幅広い互換性

JPEG(Joint Photographic Experts Group)

  • 非可逆圧縮(ファイルサイズが小さい)
  • 透過非サポート
  • 写真コンテンツに適している
  • テキストが多いダイアグラムには不向き

PDF(Portable Document Format)

  • ベクター形式(品質劣化なしで拡大縮小)
  • 印刷に最適
  • テキストを検索可能・選択可能な状態で保持
  • 複数ページをサポート

SVG(Scalable Vector Graphics)

  • ベクター形式
  • ベクターエディタ(Illustrator、Figmaなど)で編集可能
  • ウェブ利用に最適
  • 品質劣化なしで無限に拡大縮小可能

VSDX(Microsoft Visio)

  • ネイティブVisio 2013+形式
  • 完全な往復:インポート → 編集 → 再書き出し
  • シェイプ、コネクタ、テキスト、スタイル、ページを保持
  • 詳細はVisioインポートと書き出しを参照

ASCIIテキスト

  • ASCIIダイアグラムページのプレーンテキスト書き出し
  • ASCIIとUnicode文字セットから選択
  • 最大行幅を設定
  • コード、ドキュメント、ターミナルへの埋め込みに最適
  • 詳細はASCIIダイアグラムを参照

画像として書き出す

ダイアグラムをビットマップ画像(PNGまたはJPEG)として書き出すには:

  1. ファイル → 画像として書き出す… に移動
  2. 表示されるダイアログで書き出しオプションを設定
  3. 書き出す をクリック
  4. 標準の保存ダイアログで保存場所を選択
  5. 保存 をクリック

書き出しオプション

「画像として書き出す」ダイアログには4つの設定があります:

形式

2つの画像形式から選択:

  • PNG — 可逆圧縮、透過をサポート。テキストやシャープなエッジのあるダイアグラムに最適。
  • JPEG — 非可逆圧縮、ファイルサイズが小さい。透過非サポート。

DPI(解像度)

出力解像度を選択:

DPIラベルスケール用途
72画面1×標準画面表示、クイックプレビュー
144Retina2×(デフォルト)高DPIディスプレイ、プレゼンテーション
300印刷約4×高品質印刷

DPI値が高いほど、より大きく詳細な画像が生成されます。

背景

  • 白(デフォルト) — 白い背景
  • 透明 — 背景なし(PNGのみ)

JPEG形式が選択されている場合、JPEGは透過をサポートしていないため、背景は自動的に白に設定され、このオプションは無効になります。

透過背景は以下の場合に便利です:

  • 他のコンテンツにダイアグラムを重ねる場合
  • ウェブサイトのグラフィック
  • カスタム背景のプレゼンテーションスライド

余白

ダイアグラムコンテンツの周囲の追加スペース(ピクセル単位)。デフォルトは 5 px です。余白なしの場合は0に設定します。

その他の書き出し方法

PDFへの書き出し

  1. ファイル → 印刷 に移動するか、Cmd+P を押す
  2. 印刷ダイアログの左下にある PDF ドロップダウンをクリック
  3. PDFとして保存 を選択

これにより、ベクターグラフィックを保持した高品質のPDFが作成されます。

SVGへの書き出し

  1. ファイル → SVGに書き出す… に移動するか、Cmd+Shift+E を押す
  2. 保存場所を選択

SVG書き出しは PRO 機能です。

詳細はSVGサポートを参照してください。

アートボードの書き出し

ページにアートボードがある場合、それぞれを個別に書き出せます:

  • ファイル → アートボードを書き出す… — アートボードを選んでPNGまたはSVGとして保存
  • ファイル → すべてのアートボードを書き出す… — すべてのアートボードをそれぞれ個別のPNGとしてフォルダに保存

解像度 として1×、2×、3×を選択できます。詳細はアートボードを参照してください。

マインドマップの書き出し

マインドマップは、ファイル メニューから Markdown、OPML、XMind としても書き出せます。マインドマップを参照してください。

Visioへの書き出し

VSDX形式への書き出しの詳細はVisioインポートと書き出しを参照してください。

ASCIIテキストへの書き出し

テキストベースの書き出しの詳細はASCIIダイアグラムを参照してください。

ベストプラクティス

ウェブ向け

  • テキストやシャープなエッジのあるダイアグラムには PNG を使用
  • インタラクティブまたはスケーラブルなグラフィックには SVG を使用
  • 高DPIスクリーンでの鮮明な表示には 144 DPI(Retina) で書き出す
  • カラーページに重ねる場合は透過背景を使用

ドキュメント向け

  • Word、Pages、印刷には PDF を使用
  • Google Docsには PNG(144または300 DPI) を使用
  • コンテンツの周囲に十分な余白を確保

プレゼンテーション向け

  • プロジェクターでの鮮明な表示には PNG(144 DPI) を使用
  • 柔軟な配置のために透過背景を使用

印刷向け

  • 最高品質には PDF を使用
  • ラスター形式では 300 DPI を使用
  • 裁ち落とし用の余白を含める

ヒント

  1. 高いDPI = 大きなファイル:300 DPIの画像は72 DPIの約4倍の大きさになります
  2. 透過をテスト:透過部分がターゲットアプリケーションで正しく表示されることを確認
  3. 元ファイルを保持:書き出しと一緒に.diagramxファイルを必ず保存
  4. 一貫した命名:整理のためにわかりやすいファイル名を使用