インターフェースの概要

Diagrammixのウィンドウは、大きなキャンバスを中心に構成されており、その上にツールバー、左側にシェイプライブラリ、右側にインスペクタがあります。

キャンバス

中央のエリアが キャンバス で、ダイアグラムを描く場所です。無限にスクロールできるワークスペースを提供します。スクロールやトラックパッドで移動でき、スクロール中に Option を押しているとポインタを中心にズームします。

ツールバー

ウィンドウ上部の ツールバー から、ツールと表示オプションにすばやくアクセスできます:

  • 元に戻す / やり直す
  • ツール — 選択、コネクタ、接続ポイントツール、テキスト、パン、ズーム、スタイルをコピー、テーブル、付箋、アートボード、マインドマップ(PRO)
  • 描画 メニュー — シェイプ(四角形、円、角丸四角形、端丸四角形)、スマートシェイプ(星、ブロック矢印、リングセグメント)、線とパス(線、矢印、多角形、パス、フリーハンド)
  • UMLページでは UML メニュー、ASCIIページではASCIIツール
  • 整列、分布、配置 の各メニュー
  • 表示の切り替え — グリッドを表示、グリッドにスナップ、ルーラー、スマートガイド、ページレイアウトを表示
  • オートスタイル メニュー
  • アイコン — アイコンライブラリパネル(Option+Cmd+I)
  • インスペクタ の切り替えと ズーム コントロール

すべてのツールの詳細については、ツール概要を参照してください。

ライブラリ

ライブラリ は左側のサイドバーです。現在の記法のシェイプとシンボル、そしてあなたの再利用可能なエレメントが含まれています。項目をキャンバスにドラッグすると追加されます。

インスペクタパネル

右側にあるのが インスペクタパネル です。4つのタブで構成されています:

  • スタイル — 塗りつぶし、ストローク、エフェクト、コネクタのオプション、要素のカラー
  • テキスト — フォント、サイズ、色、配置、パディング、コネクタのラベル
  • 配置 — ジオメトリ(位置、サイズ、回転)、テーブル、UML、自動レイアウト
  • 書類 — レイヤーとアートボード、スマートコネクタの設定、テーマスタイル、ドキュメントカラー、キャンバスの背景

何も選択されていないときインスペクタは 書類 タブで開き、何かを選択すると スタイル に切り替わります。インスペクタパネルを参照してください。

ドキュメントタブ

1つのドキュメントには複数のページを含めることができ、キャンバスの上にタブとして表示されます。ドキュメントタブを参照してください。

ルーラー

ルーラー は、キャンバスの上端と左端に沿って計測の基準を提供します。

  • ツールバーの ルーラー ボタンで表示・非表示を切り替え
  • ルーラーからキャンバスへドラッグしてガイドラインを作成

ルーラー

元に戻す・やり直し

Diagrammixは、各ページにつき最大200件の取り消し履歴を保持します。

  • 元に戻す:Cmd+Z を押して変更を1つ前に戻す
  • やり直す:Shift+Cmd+Z を押して元に戻した変更を再適用
  • メニューバーの 編集 → 元に戻す および 編集 → やり直す も使用可能

最近使ったドキュメント

  • ファイル → 最近使った項目を開く で最近開いたファイルを表示。メニューをクリア でリストを空にします
  • Diagrammixの起動時、テンプレート選択画面に 最近の書類 のリストが表示されます。新しいダイアグラムを始めるには 書類を作成 を、ファイルを探すには ドキュメントを開く... を選びます