マインドマップ
マインドマップは、アイデアをすばやく書き留めて、分岐した階層に整理するための方法です。Diagrammixには専用のマインドマッピングモードが搭載されており、マップ全体が1つの連結した構造として動作します。ノードを追加するとレイアウトが自動的に再配置されるため、タイピングの速度で考えることができます。
注: マインドマップは PRO 機能です。
マインドマップの作成
- ツールバーから マインドマップ ツールを選択
- キャンバスの任意の場所をクリック
Diagrammixが、バランスの取れたいくつかの子ブランチを持つルートノードを作成し、すぐに入力できる状態になります。マップは常に整った状態を保ちます — ノードを追加、削除、並べ替えるたびに、ブランチが自動的に再配置されます。
キーボードでマップを構築する
マインドマップは、キーボードから手を離さずに育てられるように設計されています。単一のノードを選択してから:
| キー | 動作 |
|---|---|
Tab | 子 ノードを追加して編集を開始 |
Return | 兄弟 ノードを追加 |
Shift+Tab | 親 ノードを追加 |
Arrow keys | ノード間で選択を移動 |
Option+Up | ノードを兄弟の中で前に移動 |
Option+Down | ノードを兄弟の中で後ろに移動 |
任意のノードをダブルクリックする(または選択したノードでそのまま入力を始める)とテキストを編集できます。
構造
マインドマップの 構造 は、ブランチの配置方法を制御します。ノードを選択した状態でインスペクタから選びます:
| 構造 | 説明 |
|---|---|
| マインドマップ | クラシックな放射状レイアウト。中央にルート、左右にバランスよくブランチを配置 |
| ロジカル | ブランチが一方向に流れる |
| 組織図 | 子が親の下に配置される — 階層構造に最適 |
| ツリー | コンパクトな親 → 子のツリー |
| カタログ | 子が親の右下に積み重なる |
| フィッシュボーン | 水平の背骨から斜めに伸びるブランチ — 原因と結果の分析に最適 |
| タイムライン | 水平軸に沿って配置されるトップレベルのブランチ |
| 縦型タイムライン | 垂直軸に沿って配置されるトップレベルのブランチ |
構造を切り替えると、マップ全体が瞬時に再配置されます — コンテンツはそのまま保たれます。
ノードのスタイル設定
マインドマップのノードを選択すると、インスペクタにマインドマップ専用のコントロールが表示されます:
- テーマ — デフォルト、ビビッド、落ち着いた、ダーク。テーマは各ブランチにまとまりのあるパレットを割り当てます
- ブランチ — 構造がサポートしている場合、コネクタの描画方法(スムーズ、直線、折れ線)を選択
- ノード形状 — 角丸、矩形、楕円、ひし形、六角形
- アイコン — ノードに絵文字や文字を1つ追加
- グループ — フレームを追加 はブランチをラベル付きの外枠で囲みます(フレームを削除 で外します)
- 要約を追加 — 兄弟ノードの範囲にラベルを付ける要約ブラケットを追加します(要約を削除 で外します)
- ノードをテーマに戻す — 手動での変更をクリアし、ノードをテーマのデフォルトに戻します
インポートと書き出し
マインドマップは、他のアウトラインツールやマインドマッピングツールと相互運用できます。
Markdown
- 編集 → Markdownをマインドマップとして貼り付け は、Markdownのアウトライン(ネストされた箇条書きまたは見出しリスト)をマインドマップに変換します
- 編集 → マインドマップをMarkdownとしてコピー は、選択したマップをMarkdownのアウトラインとしてコピーします
ファイル
ファイル → エクスポート から、マインドマップを次の形式で保存できます:
- Markdown(
.md) - OPML(
.opml) — アウトライナーや他のマインドマッピングアプリ向け - XMind(
.xmind)
ノードの検索
大きなマップでは、編集 → マインドマップノードを検索… を使って名前でノードに直接ジャンプできます。
ヒント
- ドラッグではなく入力する —
TabとReturnでマップ全体を育て、配置は自動レイアウトに任せる - 構造は最後に選ぶ — まずアイデアを書き留め、それから構造を切り替えて最も明快な配置を見つける
- アイコンは控えめに使う — いくつかの絵文字で重要なブランチを見つけやすくする
- テーマごとにフレームでグループ化する — 関連するブランチをラベル付きフレームで囲み、セクションを視覚的にグループ化する
- アウトラインを往復させる — Markdownで下書きし、マインドマップとして貼り付け、調整してからコピーして戻す