SVG 支持

Diagrammix 可以在画布上放置 SVG(可缩放矢量图形)作品,并将您的页面导出为 SVG 文件。

注意: SVG 导入和 SVG 导出是 PRO 功能。

导入 SVG

有两种方式可以引入 SVG 文件:

  • 将 SVG 文件拖到画布上——它会作为 SVG 图像放置。其轮廓会被自动检测,因此连接器会附着在作品的边缘,而不是其边界框上。
  • 显示 → 管理剪贴画… → 导入 SVG…——将该 SVG 添加到您的剪贴画库,以便在任何文档中重复使用。

使用已放置的 SVG

已放置的 SVG 表现得像一张图像:可以从其浮动工具栏移动、调整大小和设置样式。

  • 色调——通过图标颜色按钮为整幅作品重新上色;参见使用图像
  • 展开——右键点击单个 SVG 图像并选择展开,将其替换为可编辑的矢量形状(和文本)。如果该作品包含多个部分,它们会被编成一组;使用编辑 → 取消编组(Shift+Cmd+G)可以分别处理它们

展开之后,您可以在检查器中更改填充和描边、编辑节点,或组合形状。选中相关部分并选择编辑 → 编组(Cmd+G)可以再次将它们组合在一起。

导出 SVG

  1. 前往**文件 → 导出为 SVG…**或按 Shift+Cmd+E
  2. 选择名称和位置,然后点击保存

会导出整个当前页面。若要将单个画板导出为 SVG,请改用文件 → 导出画板…。

兼容性说明

  • 简单的 SVG 效果最好——图标、徽标和插画
  • SVG 文件中的文本如果未安装原始字体,可能会以替代字体渲染
  • 复杂的滤镜和蒙版在展开后可能看起来不完全一致

相关主题