Obsługa SVG

Diagrammix może umieszczać grafikę SVG (Scalable Vector Graphics) na płótnie i eksportować Twoje strony jako pliki SVG.

Uwaga: Import i eksport SVG to funkcje PRO.

Importowanie SVG

Są dwa sposoby, aby wprowadzić pliki SVG:

  • Przeciągnij plik SVG na płótno — zostanie umieszczony jako obraz SVG. Jego kontur jest wykrywany automatycznie, dzięki czemu łączniki przyczepiają się do krawędzi grafiki, a nie do jej prostokąta otaczającego.
  • Widok → Zarządzaj grafiką… → Importuj SVG… — dodaje SVG do biblioteki clipartów, dzięki czemu możesz go użyć ponownie w dowolnym dokumencie.

Praca z umieszczonymi plikami SVG

Umieszczony SVG zachowuje się jak obraz: przenoś go, zmieniaj rozmiar i stylizuj z jego pływającego paska narzędzi.

  • Odcień — przekoloruj całą grafikę przyciskiem Kolor ikony; zobacz Praca z obrazami
  • Rozwiń — kliknij prawym przyciskiem myszy pojedynczy obraz SVG i wybierz Rozwiń, aby zastąpić go edytowalnymi kształtami wektorowymi (i tekstem). Jeśli grafika ma kilka części, są one grupowane; użyj Edycja → Rozgrupuj (Shift+Cmd+G), aby pracować nad nimi osobno

Po rozwinięciu możesz zmieniać wypełnienia i obrysy w Inspektorze, edytować węzły lub łączyć kształty. Zaznacz powiązane części i wybierz Edycja → Grupuj (Cmd+G), aby ponownie utrzymać je razem.

Eksportowanie SVG

  1. Przejdź do Plik → Eksportuj do SVG… lub naciśnij Shift+Cmd+E
  2. Wybierz nazwę i lokalizację, a następnie kliknij Zapisz

Eksportowana jest cała bieżąca strona. Aby wyeksportować jako SVG pojedynczy obszar roboczy, użyj zamiast tego Plik → Eksportuj obszar roboczy….

Uwagi dotyczące kompatybilności

  • Proste pliki SVG działają najlepiej — ikony, logotypy i ilustracje
  • Tekst w plikach SVG może być renderowany zastępczą czcionką, jeśli oryginalna nie jest zainstalowana
  • Złożone filtry i maski mogą wyglądać inaczej po rozwinięciu

Powiązane tematy