Praca z kształtami
Kształty to podstawowe elementy budulcowe diagramów.
Dodawanie kształtów
- Z biblioteki — przeciągnij symbol z paska bocznego biblioteki po lewej stronie na płótno
- Z menu Draw — kliknij Draw na pasku narzędzi, wybierz kształt (Prostokąt, Okrąg, Zaokrąglony prostokąt, Prostokąt z zaokrąglonymi końcami lub jeden z Inteligentnych kształtów), a następnie przeciągnij na płótnie
Zobacz Rysowanie wektorowe, aby poznać linie, wielokąty, ścieżki i rysowanie odręczne.
Zaznaczanie i przesuwanie
Użyj narzędzia Zaznacz (V), aby pracować z kształtami:
- Kliknij kształt, aby go zaznaczyć
- Cmd+kliknięcie, aby dodać kształt do zaznaczenia lub usunąć go z niego
- Przeciągnij prostokąt zaznaczenia wokół kilku elementów (przytrzymaj Cmd, aby dodać je do bieżącego zaznaczenia)
- Przeciągnij zaznaczone kształty, aby je przesunąć
- Klawisze strzałek przesuwają zaznaczenie o 1 punkt; przytrzymaj Shift, aby przesuwać o 10 punktów
Zmiana rozmiaru
Gdy kształt jest zaznaczony, uchwyty zmiany rozmiaru pojawiają się w jego narożnikach i na krawędziach. Przeciągnij uchwyt, aby zmienić rozmiar kształtu. Dla dokładnych wartości użyj zakładki Rozmieść Inspektora → sekcja Geometria.
Obracanie
Kształty, ścieżki wektorowe i obrazy mają uchwyt obrotu po zaznaczeniu — przeciągnij go, aby obrócić. Aby wprowadzić dokładny kąt, użyj Rozmieść → Geometria → Obrót w Inspektorze. Przy włączonym Przyciąganiu do siatki obrót przyciąga się co 15°.
Pasek akcji kształtu
Kliknij dwukrotnie kształt, aby otworzyć jego pływający pasek akcji:
| Przycisk | Działanie |
|---|---|
| Edytuj tekst | Edytuj tekst kształtu (możesz też zaznaczyć kształt i nacisnąć T) |
| Zamień kształt | Zamień symbol na inny, zachowując połączenia — zobacz Zamiana kształtów |
| Styl kształtu | Opcje tła, konturu i cienia |
| Schemat kolorów | Przekoloruj symbol jednym ze schematów kolorów notacji |
| Utwórz łącznik | Rozpocznij łącznik od tego kształtu |
Więcej operacji na kształtach
- Duplikuj — Edycja → Duplikuj (
Cmd+D) - Krok i powtórz — Edycja → Powtórz… (
Shift+Cmd+D), zobacz Powtórz - Połącz — Edycja → Połącz (Suma, Różnica, Iloczyn, Wykluczenie), zobacz Łączenie kształtów
- Kolejność ułożenia — menu Rozmieść kolejność Z na pasku narzędzi: Przenieś na wierzch, Przenieś do przodu, Przenieś do tyłu, Przenieś na spód
- Wyrównaj i rozłóż — menu Wyrównaj i Rozłóż na pasku narzędzi, zobacz Wyrównanie
- Grupuj — Edycja → Grupuj (
Cmd+G), zobacz Grupy